Help! Outlook 2016 client not syncing emails

mail

(kieran) #1

I’m Using the latest version.

The folder names all sync up.
My iPhone can sync up ok.
But Outlook won’t. (EAS)

The ost was about 5gb (Local cache) 20k messages split across 10 folders.

It just sits there saying ‘Waiting for server rsponse’

I have tried deleting everything and starting again but no change.
I don’t have this issue with small mailboxes, Or if I remove 99% of the mail and start again, or add it all very slowly.


(kieran) #2

Found the following on iredmail, wonder if this applies to me.

Changed everything to default iRedMail configuration added to /etc/sogo/sogo.conf :
SOGoMaximumSyncWindowSize = 100;
SOGoMaximumSyncResponseSize = 5172;
This limits Active Sync to maximum 100 items per sync request and maximum 5172kb per sync request (if you have an email with a 10mb attached it will sync only that email).

Now Outlook syncs works with no issues on large mailboxes.

If this settings are not set Outlook will try to fetch 500 items per request and sync will break because connection timeouts.
I recommend that these 2 setting be added to the next version of iRedMail by default.


(kieran) #3

OK, it seems this might be covered here. (I might not be on the latest version)
http://docs.nethserver.org/en/v7/sogo.html

Added the two entries to the SOGo conf.mas

Will monitor performance.


(kieran) #4

Ok, adding the settings above solves most of the issue. However, it still takes a very long time to download the users mailbox from the server. About a day for 1 user.
What should it take for a single user with a 5gb mailbox?
Does anyone save the ost file before reloading a system? or just let it re-sync?


(Markus Neuberger) #5

I think best way is to just resync. OST restore is a kind of last possible restore solution: